summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-01 17:07:57 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-02 10:14:19 +0100
commitcd472d1d8489f30797f47d3f6dafede28c1feb90 (patch)
tree70a07dff0256ee0089d2024a7500cb92f02f4946 /configure.ac
parent88657bf4bed6754c182b08a442d8582a7ad30ece (diff)
Compile as C++2a, where available
Change-Id: I6382be559a0c70d899d48d11e6f9b10ef270c9a4 Reviewed-on: https://gerrit.libreoffice.org/62744 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4c1583ce0705..aeaaa709135d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6200,7 +6200,7 @@ elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
printf 'foo\n' | $GPERF -L C++ > conftest.inc
my_flags='-std=gnu++14 -std=gnu++1y -std=c++14 -std=c++1y -std=gnu++11 -std=gnu++0x -std=c++11 -std=c++0x'
if test "$enable_c__17" != no; then
- my_flags="-std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z $my_flags"
+ my_flags="-std=gnu++2a -std=c++2a -std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z $my_flags"
fi
for flag in $my_flags; do
if test "$COM" = MSC; then