summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2016-06-02 13:37:02 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2016-06-02 13:37:02 +0200
commitc58cd511ab6c280a72ed725dbca653d3b1274f2a (patch)
treee0af1d2289eea7532fb5da1f1e746f75a5e29150 /configure.ac
parent2cf09f0dcfa4b24a6c3c5560aa82b72a95a7b41b (diff)
allow use of android ndk 11.1.x
Change-Id: I1ae9419383c56a026d05d6adf4adf81dc981f56a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index db1b0ae50b10..8bdee1d3820d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -349,15 +349,21 @@ if test -n "$with_android_ndk"; then
# Set up a lot of pre-canned defaults
if test ! -f $ANDROID_NDK_HOME/RELEASE.TXT; then
- AC_MSG_ERROR([Unrecognized Android NDK. Missing RELEASE.TXT file in $ANDROID_NDK_HOME.])
+ if test ! -f $ANDROID_NDK_HOME/source.properties; then
+ AC_MSG_ERROR([Unrecognized Android NDK. Missing RELEASE.TXT or source.properties file in $ANDROID_NDK_HOME.])
+ fi
+ ANDROID_NDK_VERSION=`sed -n -e 's/Pkg.Revision = //p' $ANDROID_NDK_HOME/source.properties`
+ else
+ ANDROID_NDK_VERSION=`cut -f1 -d' ' <$ANDROID_NDK_HOME/RELEASE.TXT`
fi
- ANDROID_NDK_VERSION=`cut -f1 -d' ' <$ANDROID_NDK_HOME/RELEASE.TXT`
case $ANDROID_NDK_VERSION in
r9*|r10*)
;;
+ 11.1.*)
+ ;;
*)
- AC_MSG_ERROR([Unsupported NDK version $ANDROID_NDK_VERSION, only r9* and r10* versions are supported])
+ AC_MSG_ERROR([Unsupported NDK version $ANDROID_NDK_VERSION, only r9*, r10* and 11.1.* versions are supported])
;;
esac