summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-10-25 23:23:18 +0200
committerTor Lillqvist <tml@collabora.com>2020-10-26 07:27:16 +0100
commitc13fd446d1e095c19e8511d1bd176edc152f2499 (patch)
treec8279b0b4312cdbd4711ed6ee7180efd84a0b27d /configure.ac
parentb61bf7c7cfcf97a5ade6d130873af146670bc2ee (diff)
Don't ever display harmless error messages from wsl-lo-helper
It is expected that some of the Registry entries that we try to read do not exist. Change-Id: I48b40cd6a3cf0961abd7259ad02da18c2ee65601 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/104787 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a6696df15f06..538112160235 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3554,7 +3554,7 @@ reg_get_value()
unset regvalue
if test "$build_os" = "wsl"; then
- regvalue=$($BUILDDIR/solenv/wsl/wsl-lo-helper.exe --read-registry $1 "$2")
+ regvalue=$($BUILDDIR/solenv/wsl/wsl-lo-helper.exe --read-registry $1 "$2" 2>/dev/null)
return
fi
@@ -3917,7 +3917,7 @@ if test "$_os" = "WINNT"; then
AC_MSG_CHECKING([for MSBuild.exe location for: $vcnumwithdot])
# Find the proper version of MSBuild.exe to use based on the VS version
- reg_get_value_32 HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/MSBuild/$vcnumwithdot/MSBuildOverrideTasksPath 2>/dev/null
+ reg_get_value_32 HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/MSBuild/$vcnumwithdot/MSBuildOverrideTasksPath
if test -n "$regvalue" ; then
AC_MSG_RESULT([found: $regvalue])
MSBUILD_PATH=`win_short_path_for_make "$regvalue"`