summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBalazs Varga <balazs.varga991@gmail.com>2022-06-13 14:49:56 +0200
committerThorsten Behrens <thorsten.behrens@allotropia.de>2022-06-13 22:25:22 +0200
commitbe2252c8d3e5d892ec1e6b12a2b55c2026597cb9 (patch)
treed053b321e390796ee4a9ca1c9940c3904a2fd71a /configure.ac
parent77a28966f06a7f872b305ff8e2c603e675a5c8d1 (diff)
Fix some cross-build targets errors
1. error - if disable JAVA is configured, set '--without-java', otherwise it breaks python for the build part. 2. error - forward '--with-vendor' setting to sub config, to avoid stupid windows system variable error. Change-Id: Icebdfc5d6d2816fa53538d83d3ea206a6e99ddd3 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/135724 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3883c3176e44..cafa0945982d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5643,7 +5643,7 @@ if test "$cross_compiling" = "yes"; then
;;
esac
else
- sub_conf_opts="$sub_conf_opts --disable-scripting"
+ sub_conf_opts="$sub_conf_opts --without-java"
fi
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_galleries" = "no" -o -z "$WITH_GALLERY_BUILD" && sub_conf_opts="$sub_conf_opts --with-galleries=no --disable-database-connectivity"
@@ -5654,6 +5654,7 @@ if test "$cross_compiling" = "yes"; then
test "$enable_wasm_strip" = "yes" && sub_conf_opts="$sub_conf_opts --enable-wasm-strip"
test "${with_system_lockfile+set}" = set && sub_conf_opts="$sub_conf_opts --with-system-lockfile=${with_system_lockfile}"
test "${enable_fuzzers}" = yes && sub_conf_opts="$sub_conf_opts --without-system-libxml"
+ test -n "$with_vendor" -a "$with_vendor" != "no" && sub_conf_opts="$sub_conf_opts --with-vendor=$with_vendor"
if test "$_os" = "Emscripten"; then
sub_conf_opts="$sub_conf_opts --without-system-libxml --without-system-fontconfig --without-system-freetype --without-system-zlib"
fi