summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHeiko Tietze <tietze.heiko@gmail.com>2021-01-08 15:10:42 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2021-01-14 20:27:59 +0100
commitbd319954e82da64d1ca037df2f32982af6ddb0e2 (patch)
treec3bdafdadaef7e0e82ad1126cc17389926532e45 /configure.ac
parent5ccbba5ab87b86c94fc3f79d89e88d7aa9456b08 (diff)
Resolves tdf#139343 and tdf#139335 - Community/Enterprise flavor
* Switch CE/EE per --disable-community-flavor internally use HAVE_FEATURE_COMMUNITY_FLAVOR * Version info in about dialog shows text depending on this flavor * Start center also shows the brand image now * TDF builds use a brand image with TDF tagline in the about dialog * Brand images with just "Community" (no Edition) Change-Id: I363dd2b39df9aad951c9d79addf9bdedfc4a3495 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108980 Tested-by: Jenkins Reviewed-by: Heiko Tietze <heiko.tietze@documentfoundation.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.com> (cherry picked from commit 2d69acfde50cb0e06a9a057939078fd102d371a3) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/109274 Tested-by: Xisco Fauli <xiscofauli@libreoffice.org> Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3428679fd82f..fba31ba74fe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1763,6 +1763,11 @@ AC_ARG_WITH(product-name,
[Define the product name. Default is AC_PACKAGE_NAME.]),
,with_product_name=$PRODUCTNAME)
+libo_FUZZ_ARG_ENABLE(community-flavor,
+ AS_HELP_STRING([--disable-community-flavor],
+ [Disable the Community branding.]),
+,)
+
AC_ARG_WITH(package-version,
AS_HELP_STRING([--with-package-version='3.1.4.5'],
[Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
@@ -2644,6 +2649,14 @@ fi
AC_SUBST(ENABLE_RELEASE_BUILD)
AC_SUBST(GET_TASK_ALLOW_ENTITLEMENT)
+AC_MSG_CHECKING([whether to build a Community flavor])
+if test -z "$enable_community_flavor" -o "$enable_community_flavor" == "yes"; then
+ AC_DEFINE(HAVE_FEATURE_COMMUNITY_FLAVOR)
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl ===================================================================
dnl Test whether to sign Windows Build
dnl ===================================================================
@@ -13434,7 +13447,7 @@ dnl ===================================================================
AC_MSG_CHECKING([for alternative branding images directory])
# initialize mapped arrays
BRAND_INTRO_IMAGES="intro.png intro-highres.png"
-brand_files="$BRAND_INTRO_IMAGES logo.svg logo_inverted.svg about.svg"
+brand_files="$BRAND_INTRO_IMAGES logo.svg logo_inverted.svg logo-sc.svg logo-sc_inverted.svg about.svg"
if test -z "$with_branding" -o "$with_branding" = "no"; then
AC_MSG_RESULT([none])