summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2016-08-04 22:48:22 +0300
committerTor Lillqvist <tml@collabora.com>2016-10-13 20:58:15 +0300
commitb7d49b078e9a8262491aac57a1533d37d3d586fc (patch)
treec5c204e193805bbfc38bc6e39adb58be7bb796f3 /configure.ac
parent79bf2fd7d6b740fbf2919d33165cb99434bdd550 (diff)
Accept also macOS SDK 10.12
Change-Id: I2e654de8af40486ef63146ad42a3f2988f9c3579
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b155bd189c3c..873dded3f223 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2825,7 +2825,7 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11; do
+ for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11 10.12; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2856,8 +2856,11 @@ if test $_os = Darwin; then
10.11)
MACOSX_SDK_VERSION=101100
;;
+ 10.12)
+ MACOSX_SDK_VERSION=101200
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--11])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--12])
;;
esac
@@ -2889,8 +2892,11 @@ if test $_os = Darwin; then
10.11)
MAC_OS_X_VERSION_MIN_REQUIRED="101100"
;;
+ 10.12)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101200"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--11])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--12])
;;
esac
@@ -2926,8 +2932,11 @@ if test $_os = Darwin; then
10.11)
MAC_OS_X_VERSION_MAX_ALLOWED="101100"
;;
+ 10.12)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101200"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--11])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--12])
;;
esac