summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDeve <deveee@gmail.com>2019-01-09 00:10:27 +0100
committerMichael Stahl <Michael.Stahl@cib.de>2019-01-11 18:28:57 +0100
commitb534c1ef4ba439cc1b0f566ed9e3a3275a2e8e5e (patch)
tree071f31a5f64d8fbe0871cb72c20347eef06ce0aa /configure.ac
parent0515ffdb2e4c975f1d19257dfed2a24ff3cbfdb4 (diff)
Don't build dconf on Android and iOS.
Without that modification, it finds dconf in linux system and then compilation fails when it tries to build configmgr/source/dconf.cxx because dconf headers are not found in Android NDK. Change-Id: I25ab7f1ce66ed491f08a526e462e00957135b0c2 Reviewed-on: https://gerrit.libreoffice.org/65987 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0a6db77f230d..d8e8e673977c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10455,7 +10455,7 @@ dnl =================================================
dnl Check whether to build with dconf support.
dnl =================================================
-if test "$enable_dconf" != no; then
+if test $_os != Android -a $_os != iOS -a "$enable_dconf" != no; then
PKG_CHECK_MODULES([DCONF], [dconf >= 0.15.2], [], [
if test "$enable_dconf" = yes; then
AC_MSG_ERROR([dconf not found])
@@ -10464,7 +10464,7 @@ if test "$enable_dconf" != no; then
fi])
fi
AC_MSG_CHECKING([whether to enable dconf])
-if test "$enable_dconf" = no; then
+if test $_os = Android -o $_os = iOS -o "$enable_dconf" = no; then
DCONF_CFLAGS=
DCONF_LIBS=
ENABLE_DCONF=