summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-23 12:11:19 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-23 17:03:59 +0100
commitb4f666f2e677b05cab8395fe7972b45b15f60c3f (patch)
treea3b8d410f30eb2393d06330f96a0b0919658d528 /configure.ac
parent3ace447b0fe1926945f739479a7be39276e81fb5 (diff)
Bump Xcode baseline to 9.3
...as discussed at <https://lists.freedesktop.org/archives/libreoffice/2018-November/081435.html> "minutes of ESC call ..." Change-Id: I47e23d222b4b27256483dfd7de915dd99ae81317 Reviewed-on: https://gerrit.libreoffice.org/63878 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 827b5f6c995e..cddfd825e4a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2773,6 +2773,16 @@ if test $_os = Darwin -o $_os = iOS; then
FRAMEWORKSHOME="$MACOSX_SDK_PATH/System/Library/Frameworks"
MACOSX_DEPLOYMENT_TARGET="$with_macosx_version_min_required"
+ AC_MSG_CHECKING([whether Xcode is new enough])
+ my_xcode_ver1=$(xcrun xcodebuild -version | head -n 1)
+ my_xcode_ver2=${my_xcode_ver1#Xcode }
+ my_xcode_ver3=$(printf %s "$my_xcode_ver2" | $AWK -F. '{ print $1*100+($2<100?$2:99) }')
+ if test "$my_xcode_ver3" -ge 903; then
+ AC_MSG_RESULT([yes ($my_xcode_ver2)])
+ else
+ AC_MSG_ERROR(["$my_xcode_ver1" is too old or unrecognized, must be at least Xcode 9.3])
+ fi
+
case "$with_macosx_version_min_required" in
10.9)
MAC_OS_X_VERSION_MIN_REQUIRED="1090"