summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHossein <hossein@libreoffice.org>2022-03-06 14:02:48 +0100
committerMichael Stahl <michael.stahl@allotropia.de>2022-03-08 10:44:18 +0100
commitabaac7a4c1b27d71c4e6f9cfb64900619a46f7f7 (patch)
treec3bffc1aee7e315ee2a6aa1a37f5a92651a3ece7 /configure.ac
parent5ffa84963cdff4d8e3f873bc54404e04b32bbdbe (diff)
tdf#147801 Demote bsdtar in favor of tar in configure.ac
The utility used to extract archives including tar.xz is chosen among 'gtar gnutar bsdtar tar' (respectively) that may be present in the system PATH. When compiling LibreOffice, there is a possiblity that some bad tools that are available in the PATH are chosen incorrectly. As an example, Anaconda on Windows provides a 'bsdtar' utility which can not handle tar.xz files, but it is chosen as the archive extraction utility. This patch demotes 'bsdtar' comapred to 'tar' in configure.ac to fix the issue, which is filed as tdf#147801. Change-Id: If6aa47b9255a54c1220bbfce6c2515dc53fb795b Reviewed-on: https://gerrit.libreoffice.org/c/core/+/130974 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3e65a8298aff..10529032c5fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2955,7 +2955,7 @@ fi
AC_SUBST(COMPRESSIONTOOL)
AC_MSG_CHECKING([for GNU or BSD tar])
-for a in $GNUTAR gtar gnutar bsdtar tar /usr/sfw/bin/gtar; do
+for a in $GNUTAR gtar gnutar tar bsdtar /usr/sfw/bin/gtar; do
$a --version 2> /dev/null | egrep "GNU|bsdtar" 2>&1 > /dev/null
if test $? -eq 0; then
GNUTAR=$a