summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-10-13 11:17:25 +0200
committerSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-10-13 11:20:38 +0200
commita1bfd9d202aebd9ccf283a8e7ef6f4e826041056 (patch)
tree5ba1732a93e2390125d0b8c471f77ac806926d3a /configure.ac
parent6a8396a3408ac86f78657f420f0b118dbe2d7a74 (diff)
Improve checking for emscripten zlib
Change-Id: I52cff17d4d909135e40be53cd5c22a1565953762
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index eb0474360f00..3bfdf586a870 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7420,17 +7420,16 @@ dnl and has no pkg-config for it at least on some tinderboxes,
dnl so leaving that out for now
dnl libo_CHECK_SYSTEM_MODULE([zlib],[ZLIB],[zlib])
AC_MSG_CHECKING([which zlib to use])
-if test "$_os" = "Emscripten"; then
- # Emscripten provides its own zlib
- AC_MSG_RESULT([Emscripten provided])
- SYSTEM_ZLIB=TRUE
-elif test "$with_system_zlib" = "yes"; then
+if test "$with_system_zlib" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_ZLIB=TRUE
- AC_CHECK_HEADER(zlib.h, [],
- [AC_MSG_ERROR(zlib.h not found. install zlib)], [])
- AC_CHECK_LIB(z, deflate, [ ZLIB=-lz ],
- [AC_MSG_ERROR(zlib not found or functional)], [])
+ if test "$_os" != "Emscripten"; then
+ # Emscripten provides its own zlib, don't check for that
+ AC_CHECK_HEADER(zlib.h, [],
+ [AC_MSG_ERROR(zlib.h not found. install zlib)], [])
+ AC_CHECK_LIB(z, deflate, [ ZLIB=-lz ],
+ [AC_MSG_ERROR(zlib not found or functional)], [])
+ fi
else
AC_MSG_RESULT([internal])
SYSTEM_ZLIB=