summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2013-05-29 10:27:25 +0300
committerTor Lillqvist <tlillqvist@suse.com>2013-05-29 10:27:25 +0300
commit9edaf808c567cb54477b522c51416921c4811d2e (patch)
tree4e5884dcf5fcec5e1949b1280a847b0c1d9d5700 /configure.ac
parent60790b3f0ccc1779bcff2ddcc278a9027aedabee (diff)
Reinstate settting of vsarch which is used a few lines below
Change-Id: I1214498e57fcbb2b7208c213a2b98dc7dc3bf3ae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ce517b31c07..13f84e9c3659 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4897,6 +4897,12 @@ find_msms()
find_msvc_x64_dlls()
{
if test "$VCVER" != "90"; then
+ if test "$CPUNAME" = "INTEL"; then
+ vsarch=x86
+ else
+ vsarch=x64
+ fi
+
msvcdllpath="$VC_PRODUCT_DIR/redist/x64/Microsoft.VC${VCVER}.CRT"
MSVC_DEBUG_DLL_PATH="$VC_PRODUCT_DIR/redist/Debug_NonRedist/$vsarch/Microsoft.VC${VCVER}.DebugCRT"
msvcdlls="msvcp${VCVER}.dll msvcr${VCVER}.dll"