summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-01-30 12:05:45 +0100
committerStephan Bergmann <sbergman@redhat.com>2019-01-30 19:03:38 +0100
commit9d985abccf0f9ae0f0bdb72741a1942d213396a4 (patch)
tree38d216765edcbf72ca14c1b8bb26f167f07cef7b /configure.ac
parent00bf2dc3ccf462174aeefca30e28a6a87a6b93ee (diff)
Avoid CFLAGS being set by accident
When no CFLAGS are passed into autogen.sh, f104b3cafee63b47a735cfdce0f05dab2eedbb91 "tdf#72987 run firebird test for little endian only for now" (introducing AC_C_BIGENDIAN before AC_PROG_CC) caused CFLAGS in config_host.mk to accidentally be set to -g -O2 (instead of being left undefined). Change-Id: I639ce74b468e7fb25a6bda97346c7f97d6b829aa Reviewed-on: https://gerrit.libreoffice.org/67125 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> (cherry picked from commit fcb08e31ee0635fe61338246a57e926c11890ac7) Reviewed-on: https://gerrit.libreoffice.org/67134 Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 515753fab1b9..6674447ecec3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -806,13 +806,6 @@ haiku*)
;;
esac
-if test "$_os" != "WINNT"; then
-AC_C_BIGENDIAN([ENDIANNESS=big], [ENDIANNESS=little])
-else
-ENDIANNESS=little
-fi
-AC_SUBST(ENDIANNESS)
-
if test "$_os" = "Android" ; then
# Verify that the NDK and SDK options are proper
if test -z "$with_android_ndk"; then
@@ -928,7 +921,7 @@ my_original_CXXFLAGS=$CXXFLAGS
my_original_CPPFLAGS=$CPPFLAGS
dnl The following checks for gcc, cc and then cl (if it weren't guarded for win32)
-dnl Needs to precede the AC_SEARCH_LIBS call below, which apparently calls
+dnl Needs to precede the AC_C_BIGENDIAN and AC_SEARCH_LIBS calls below, which apparently call
dnl AC_PROG_CC internally.
if test "$_os" != "WINNT"; then
# AC_PROG_CC sets CFLAGS to -g -O2 if not set, avoid that
@@ -937,6 +930,13 @@ if test "$_os" != "WINNT"; then
CFLAGS=$save_CFLAGS
fi
+if test "$_os" != "WINNT"; then
+AC_C_BIGENDIAN([ENDIANNESS=big], [ENDIANNESS=little])
+else
+ENDIANNESS=little
+fi
+AC_SUBST(ENDIANNESS)
+
if test $_os != "WINNT"; then
save_LIBS="$LIBS"
AC_SEARCH_LIBS([dlsym], [dl],