summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-03-08 15:54:08 +0200
committerTor Lillqvist <tml@collabora.com>2017-03-08 15:54:08 +0200
commit9c0a5c211079be9436d58c6ca596df30ed93d8bb (patch)
tree4d3b896148d70215b3e6e47378a1b1f390acd164 /configure.ac
parent587cf92e5cff091f863227fffa347df875fb86f7 (diff)
Adapt path to the CRT redist for VS2017 build 14.10.25017
Seems that they added an "onecore" directory level before the "x64". At least in the Community Edition.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 57506a061f32..49b060739508 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5358,7 +5358,11 @@ find_msvc_x64_dlls()
{
msvcdllpath="$VC_PRODUCT_DIR/redist/x64/Microsoft.VC${VCVER}.CRT"
if test "$VCVER" = 150; then
- msvcdllpath="$VC_PRODUCT_DIR/redist/MSVC/$vcbuildnumber/x64/Microsoft.VC${VCVER}.CRT"
+ if test $vcbuildnumber = 14.10.25017; then
+ msvcdllpath="$VC_PRODUCT_DIR/redist/MSVC/$vcbuildnumber/onecore/x64/Microsoft.VC${VCVER}.CRT"
+ else
+ msvcdllpath="$VC_PRODUCT_DIR/redist/MSVC/$vcbuildnumber/x64/Microsoft.VC${VCVER}.CRT"
+ fi
fi
# http://blogs.msdn.com/b/vcblog/archive/2014/06/03/visual-studio-14-ctp.aspx
# Refactored C Runtime (CRT): This CTP contains the first preview of the substantially refactored CRT.