summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2015-10-13 05:20:24 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2015-10-13 05:22:10 -0500
commit9af1331c9253426855ac0f3a26e7f4bfff900d61 (patch)
treeaf53922ec278e9e17d1e21144e7002c1c9528d57 /configure.ac
parent98528be2fe1160d45f62222193da482f5bb06d00 (diff)
For now, firebird doe snot build on macosx 10.11
upstream seems to be working on it, for now just turn it off when building with SDK 10.11 Change-Id: I07efbf7fb363f4ea09ad42f9f6a1d7303c60da56
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3bfdf586a870..5b8b3a8aa4b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1415,7 +1415,7 @@ AC_ARG_ENABLE(lotuswordpro,
AC_ARG_ENABLE(firebird-sdbc,
AS_HELP_STRING([--disable-firebird-sdbc],
[Disable the build of the Firebird-SDBC driver if it doesn't compile for you.]),
-,enable_firebird_sdbc=yes)
+)
AC_ARG_ENABLE(winegcc,
AS_HELP_STRING([--enable-winegcc],
@@ -8440,7 +8440,15 @@ dnl ===================================================================
dnl Check for Firebird stuff
dnl ===================================================================
ENABLE_FIREBIRD_SDBC=""
-if test "x$enable_firebird_sdbc" = "xyes"; then
+if test -z "$enable_firebird_sdbc" ; then
+ if test "$_os" = "Darwin" -a "$MACOSX_SDK_VERSION" -ge 101100 ; then
+ AC_MSG_NOTICE([firebird does not build on 10.11.. default to --disable-firebird-sdbc ])
+ enable_firebird_sdbc="no"
+ else
+ enable_firebird_sdbc="yes"
+ fi
+fi
+if test "$enable_firebird_sdbc" = "yes" ; then
SCPDEFS="$SCPDEFS -DWITH_FIREBIRD_SDBC"
dnl ===================================================================