summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-03-21 22:05:10 +0100
committerMichael Stahl <mstahl@redhat.com>2017-03-22 10:30:40 +0100
commit9727857420004905c877963ca62b8b3d88e4afe3 (patch)
treeee168d14bed67477a724395d2d0763bddc48b827 /configure.ac
parent10aff2905c51319c2cfa5d8f85fc9a32d80c2e25 (diff)
configure: MSVC 2017 devenv.exe doesn't start properly
... from a DOS style 8.3 path, for whatever reason. Special case DEVENV variable so it uses long path. Change-Id: I03bb20a8f35cd116edd33ec91178f9deddbc4257
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b50b44521725..fd44c66ba942 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3451,10 +3451,13 @@ if test "$_os" = "WINNT"; then
fi
# Find the version of devenv.exe
- DEVENV="$VC_PRODUCT_DIR/../Common7/IDE/devenv.exe"
+ # MSVC 2017 devenv does not start properly from a DOS 8.3 path
+ DEVENV=$(cygpath -lm "$VC_PRODUCT_DIR/../Common7/IDE/devenv.exe")
if test ! -e "$DEVENV"; then
AC_MSG_ERROR([No devenv.exe found, Visual Studio installation broken?])
fi
+ # add quotes around it, this is an ugly hack for convenience
+ DEVENV=\"${DEVENV}\"
dnl ===========================================================
dnl Check for the corresponding mspdb*.dll