summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkash Jain <akash96j@gmail.com>2016-05-23 18:52:56 +0530
committerKhaled Hosny <khaledhosny@eglug.org>2016-05-24 20:59:44 +0000
commit9364a49a87684e54b7b04a6a110a2325bff5d96b (patch)
tree5d066ee30217c5c03a4a0a77b1266c2e29bfc606 /configure.ac
parentd5397bf17d1b2d268c1d5905079b69619ea0467a (diff)
Add option to enable HarfBuzz support independent of platform
Make HarfBuzz compile on any platform using the --with-harfbuzz option. Support is experimental only. Change-Id: I84fb80f3f8abed8ac877a294cf7ef39cf4cb2e9e Reviewed-on: https://gerrit.libreoffice.org/25369 Reviewed-by: Khaled Hosny <khaledhosny@eglug.org> Tested-by: Khaled Hosny <khaledhosny@eglug.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 86cc7b687697..44f6e87b69b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2131,6 +2131,12 @@ AC_ARG_WITH(iwyu,
Use only if you are hacking on it.]),
,)
+AC_ARG_WITH(harfbuzz,
+ AS_HELP_STRING([--with-harfbuzz],
+ [Enable HarfBuzz support regardless of the platform.
+ Experimental only. Use only if working on it.]),
+,)
+
dnl ===================================================================
dnl Branding
dnl ===================================================================
@@ -9205,7 +9211,7 @@ dnl ===================================================================
dnl HarfBuzz
dnl ===================================================================
AC_MSG_CHECKING([whether to enable HarfBuzz support])
-if test $_os != WINNT -a $_os != Darwin -a $_os != iOS; then
+if test "$with_harfbuzz" = "yes" -o \( $_os != WINNT -a $_os != Darwin -a $_os != iOS \); then
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then