summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2022-11-23 15:48:27 +0200
committerThorsten Behrens <thorsten.behrens@allotropia.de>2022-11-29 01:56:02 +0100
commit8aef8c3a1451b2fce37a21870a004855822ee335 (patch)
treeb3af1371e2326d1e66c88ce5f700fcb43f5d4cdd /configure.ac
parentdff1d7526f8b9d98c864a32654820cf92196ccbf (diff)
Make it possible to run either Writer or Calc in the same Emscripten thing
If no --with-main-module option is used, don't strip either. To switch, you need to edit the instdir/program/soffice.js . (Or static/emscripten/soffice_args.js and re-make.) Change-Id: I572a777134e7b29fc4896e7b094ceca521874ae1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/143396 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d0ccebda32a..bea2bd98a22e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3937,7 +3937,7 @@ if test "$cross_compiling" = "yes"; then
if test "$_os" = "Emscripten"; then
if test "$with_main_module" = "calc"; then
ENABLE_WASM_STRIP_WRITER=TRUE
- else
+ elif test "$with_main_module" = "writer"; then
ENABLE_WASM_STRIP_CALC=TRUE
fi
fi