summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-03-02 17:28:00 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-03-02 17:28:00 +0100
commit8934a3b1e29a80ce7f0ae0c59c4a3add84a0d72a (patch)
tree137b86af1b6acd734abe38ac63b869d99ccf76e0 /configure.ac
parent84b36c704d73362d4d86dc9e9c0efa0625958347 (diff)
Remove HAVE_GCC_VISIBILITY_BROKEN check completely now
...after 5.3 branch-off, cf. 1ea987f23a4514bcae5a6bd98014ade1af4a0107 "Remove HAVE_GCC_VISIBILITY_BROKEN, never true" Change-Id: Ibc6a059d5704c3ceafffef578bf61abe202dbdd6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 76da4e4703e4..a4f0503aa3e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6370,31 +6370,6 @@ if test "$_os" != "WINNT"; then
fi
fi
- sharedlink_ldflags_save=$LDFLAGS
- LDFLAGS="$LDFLAGS -fvisibility-inlines-hidden $PICSWITCH $LINKFLAGSSHL"
-
- AC_MSG_CHECKING([if gcc is -fvisibility-inlines-hidden safe with STL headers])
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include <sstream>
-using namespace std;
- ]], [[
-istringstream strm( "test" ); return 0;
- ]])],
- # Ugh, surely bad to assume an error message will contain
- # the word "unresolvable", a problem with
- # -fvisibility-inlines-hidden and STL headers might cause
- # some more obscure message on some platform, and anway,
- # the error message could be localised.
- [$EGREP -q unresolvable conftest.err;
- if test $? -eq 0; then gccvisok=no; else gccvisok=yes; fi],[gccvisok=no
- ])
- AC_MSG_RESULT([$gccvisok])
- if test "$gccvisok" = "no"; then
- AC_MSG_ERROR([Your gcc is not -fvisibility-inlines-hidden safe. This is no longer supported.])
- fi
-
- LDFLAGS=$sharedlink_ldflags_save
-
# As the below test checks things when linking self-compiled dynamic libraries, it presumably is irrelevant
# when we don't make any dynamic libraries?
if test "$DISABLE_DYNLOADING" = ""; then