summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-05-25 10:11:54 +0300
committerTor Lillqvist <tml@collabora.com>2020-05-25 12:04:10 +0200
commit88bd1509bf12e668a3a4107af42e8918171a7690 (patch)
treed76c59c3eeee1bf4f7b5569bb0a392273e2121f6 /configure.ac
parent9cbde4be33d82fc822b11394e713b8d2492bcac8 (diff)
Enforce "internal" or "fully-internal" Python on macOS
Offering a wider choice is pointless. There is no system Python on end-user machines, and besides, trying to build against the Python bundled with Xcode apparently causes compilation warnings. Change-Id: Iba24da1de36705df60cc5cf349885a7bae0ab879 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/94769 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 66e466b5297d..8f9e1c71047a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1245,9 +1245,12 @@ AC_ARG_ENABLE(lto,
AC_ARG_ENABLE(python,
AS_HELP_STRING([--enable-python=<no/auto/system/internal/fully-internal>],
[Enables or disables Python support at run-time.
- Also specifies what Python to use. 'auto' is the default.
+ Also specifies what Python to use at build-time.
'fully-internal' even forces the internal version for uses of Python
- during the build.]))
+ during the build.
+ On macOS the only choices are
+ 'internal' (default) or 'fully-internal'. Otherwise the default is 'auto'.
+ ]))
libo_FUZZ_ARG_ENABLE(gtk3,
AS_HELP_STRING([--disable-gtk3],
@@ -8773,6 +8776,10 @@ AC_SUBST(XMLLINT)
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
+if test $_os = Darwin -a "$enable_python" != fully-internal -a "$enable_python" != internal; then
+ # Only allowed choices for macOS are 'internal' (default) and 'fully-internal'
+ enable_python=internal
+fi
if test "$build_os" != "cygwin" -a "$enable_python" != fully-internal; then
if test -n "$PYTHON"; then
PYTHON_FOR_BUILD=$PYTHON