summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Yee <ny.nathan.yee@gmail.com>2015-07-03 11:58:27 +0200
committerJan Holesovsky <kendy@collabora.com>2015-07-03 13:49:20 +0200
commit7eb863d6b6258f31343d4b0b82038afe5e036bc0 (patch)
tree55e80346723af4883cfe0a896a50c95cb48d91c2 /configure.ac
parentba1d870abf1b12fd4ac4ba353d39d20bc9bb3a0e (diff)
online update: Add the bzip2 external.
Change-Id: Id7547390c49c0bcf672eb1a9863fc236518bfa49
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06b2d5e32317..0325a2fbd1f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1574,6 +1574,11 @@ AC_ARG_WITH(system-libs,
[Use libraries already on system -- enables all --with-system-* flags.]),
,)
+AC_ARG_WITH(system-bzip2,
+ AS_HELP_STRING([--with-system-bzip2],
+ [Use bzip2 already on system. Used only when --enable-online-update=mar]),,
+ [with_system_bzip2="$with_system_libs"])
+
AC_ARG_WITH(system-headers,
AS_HELP_STRING([--with-system-headers],
[Use headers already on system -- enables all --with-system-* flags for
@@ -11807,6 +11812,25 @@ AC_SUBST(ENABLE_ONLINE_UPDATE)
AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
dnl ===================================================================
+dnl Test whether we need bzip2
+dnl ===================================================================
+SYSTEM_BZIP2=
+if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE"; then
+ AC_MSG_CHECKING([whether to use system bzip2])
+ if test "$with_system_bzip2" = yes; then
+ SYSTEM_BZIP2=TRUE
+ AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES(BZIP2, bzip2)
+ else
+ AC_MSG_RESULT([no])
+ BUILD_TYPE="$BUILD_TYPE BZIP2"
+ fi
+fi
+AC_SUBST(SYSTEM_BZIP2)
+AC_SUBST(BZIP2_CFLAGS)
+AC_SUBST(BZIP2_LIBS)
+
+dnl ===================================================================
dnl Test whether to enable extension update
dnl ===================================================================
AC_MSG_CHECKING([whether to enable extension update])