summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-14 14:02:14 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-14 14:04:23 +0200
commit7df1b63be25d7b7eaeccb3b13a81b4370240bc10 (patch)
tree61e50c148e9b77b980651d8a14b7f21a82af03df /configure.ac
parentea11587a750023806a884c2b74ae728fb60340d5 (diff)
add warning with install command when android support repository is missing
Change-Id: I21f4bc6fe6cb10e57c45880a4b6d1be2e4fb88d2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5aed6eb7eb03..98c2253b76e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -858,6 +858,14 @@ if echo "$host_os" | grep -q linux-android ; then
add_warning " $ANDROID_SDK_HOME/tools/android update sdk -u --all --filter build-tools-$BUILD_TOOLS_VERSION"
add_warning "or adjust $SRC_ROOT/android/source/build.gradle accordingly"
fi
+ if test ! -f "$ANDROID_SDK_HOME/extras/android/m2repository/source.properties"; then
+ AC_MSG_WARN([android support repository not found - install with
+ $ANDROID_SDK_HOME/tools/android update sdk -u --filter extra-android-m2repository
+ to allow the build to download the specified version of the android support libraries])
+ add_warning "android support repository not found - install with"
+ add_warning " $ANDROID_SDK_HOME/tools/android update sdk -u --filter extra-android-m2repository"
+ add_warning "to allow the build to download the specified version of the android support libraries"
+ fi
fi
if test "$_os" = "AIX"; then