summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-11-24 22:58:01 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-11-24 23:21:37 +0100
commit7bf64a5af4088c0f6d4dbf7f493e94fa63e2a4b2 (patch)
tree1b5203554f998da6402ee482da1499f6568bf31a /configure.ac
parent774003e87946ca9dc63b1c1c550be968016d1e53 (diff)
Turn PDF import from bundled extension to plain code
No need for dirty hacks linking in basegfx objects statically any more. To avoid unnecessary confusion between the newly plain code and any instance of the old extension still installed (per-user or shared), I renamed all relevant UNO implementation identifiers from com.sun.star.comp.documents.* to org.libreoffice.comp.documents.*. Also, existing installations of the extension are explicitly not migrated to new user profiles. The xpdfimport executable is now in program/, its xpdfimport_err.pdf in share/xpdfimport/. To simplify finding the _err.pdf from xpdfimport, its full pathname is now given as additional second argument to xpdfimport. To find xpdfimport executable from CppunitTest, CppunitTest creates a symlink from solver's unittest/installation/program to solver's bin, so that "$BRAND_BASE_DIR/program/xpdfimport" works there (as CppunitTest now sets BRAND_BASE_DIR to solver's unittest/installation). The sdext/source/pdfipmort/dialogs/ Basic stuff appeared to be unused (even though it was included in the .oxt) and has been removed. The --disable-ext-pdfimport configure switch is renamed to --disable-pdfimport. Having it still conditional requires some pdf_Portable_Document_Format vs. pdf_Portable_Document_Format_import foo in module filter. Change-Id: Iee58c2f6187142a418decc9ea3a5df10eb7e0523
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index add46ca0c8be..605dd1aa2b6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -569,6 +569,11 @@ AC_ARG_ENABLE(extensions,
[Disable all add-on extension functionality. Work in progress, use only if you are hacking on it.])
)
+AC_ARG_ENABLE(pdfimport,
+ AS_HELP_STRING([--disable-pdfimport],
+ [Disable PDF import.])
+)
+
AC_ARG_ENABLE(scripting,
AS_HELP_STRING([--disable-scripting],
[Disable BASIC, Java and Python. Work in progress, use only if you are hacking on it.])
@@ -627,11 +632,6 @@ AC_ARG_ENABLE(ext-oooblogger,
[Enable the OOo Blogger extension.])
)
-AC_ARG_ENABLE(ext-pdfimport,
- AS_HELP_STRING([--disable-ext-pdfimport],
- [Disable the PDF Import extension.])
-)
-
AC_ARG_ENABLE(ext-presenter-minimizer,
AS_HELP_STRING([--disable-ext-presenter-minimizer],
[Disable the Presentation Minimizer extension.])
@@ -1383,7 +1383,7 @@ AC_ARG_WITH(system-openldap,
AC_ARG_WITH(system-poppler,
AS_HELP_STRING([--with-system-poppler],
- [Use system poppler. (only needed for pdfimport extension)]),,
+ [Use system poppler (only needed for PDF import).]),,
[with_system_poppler="$with_system_libs"])
AC_ARG_WITH(system-apache-commons,
@@ -9824,9 +9824,9 @@ else
fi
AC_SUBST(ENABLE_MINIMIZER)
-# pdf import extension?
-AC_MSG_CHECKING([whether to build the PDF Import extension])
-if test "x$enable_ext_pdfimport" != "xno" -a "x$enable_extension_integration" != "xno"; then
+# pdf import?
+AC_MSG_CHECKING([whether to build the PDF import])
+if test "x$enable_pdfimport" != "xno"; then
AC_MSG_RESULT([yes])
ENABLE_PDFIMPORT=YES
@@ -9857,7 +9857,7 @@ if test "x$enable_ext_pdfimport" != "xno" -a "x$enable_extension_integration" !=
else
AC_MSG_RESULT([no])
ENABLE_PDFIMPORT=NO
- SCPDEFS="$SCPDEFS -DWITHOUT_EXTENSION_PDFIMPORT"
+ SCPDEFS="$SCPDEFS -DWITHOUT_PDFIMPORT"
fi
AC_SUBST(ENABLE_PDFIMPORT)
AC_SUBST(SYSTEM_POPPLER)