summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2014-12-07 21:48:55 +0100
committerDavid Tardon <dtardon@redhat.com>2014-12-08 00:01:35 +0100
commit764836cb00e8e6dfd2ab48e080a166ec90359e01 (patch)
treee9b6f405fac23f911e7e663ffb5ec06b26e9921d /configure.ac
parentb19fefa01c185cfc2d2386e8c8ddd7327b7540ff (diff)
Revert "No need to have OpenCL optional at configure-time"
As long as this requires bundling clcc, not allowing to disable it is unacceptable. This reverts commit 3b0b76462aa54f60bc9823d9c6ef64e5e35c1208. Conflicts: configure.ac Change-Id: I12b3d5e3325bbd03cd98e1fb5139705d694493c2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b6ae6db2ce87..e969fbfd68d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1096,6 +1096,10 @@ AC_ARG_ENABLE(cairo-canvas,
platforms where Cairo is available.
])
+AC_ARG_ENABLE(opencl,
+ AS_HELP_STRING([--disable-opencl],
+ [Determines whether to build with OpenCL support.]))
+
AC_ARG_ENABLE(dbus,
AS_HELP_STRING([--disable-dbus],
[Determines whether to enable features that depend on dbus.
@@ -10263,13 +10267,21 @@ dnl =================================================
dnl Check whether to build with OpenCL support.
dnl =================================================
-if test $_os != iOS -a $_os != Android; then
+AC_MSG_CHECKING([whether to build with the OpenCL support.])
+ENABLE_OPENCL=
+
+if test $_os != iOS -a $_os != Android -a "x$enable_opencl" != "xno"; then
+ AC_MSG_RESULT([yes])
# CLCC in BUILD_TYPE tells that we are building a bundled clcc (just the clew part), OPENCL in
# BUILD_TYPE tells that OpenCL is potentially available on the platform (optional at run-time,
# used through clew).
BUILD_TYPE="$BUILD_TYPE CLCC OPENCL"
+ ENABLE_OPENCL=TRUE
AC_DEFINE(HAVE_FEATURE_OPENCL)
+else
+ AC_MSG_RESULT([no])
fi
+AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================
dnl Check whether to enable glTF support