summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-07-11 17:13:01 +0300
committerTor Lillqvist <tml@iki.fi>2013-07-11 17:15:23 +0300
commit74388d2fbdd3ffb7d319e74dd1a7c5592410aacd (patch)
tree998af5ef89f9783ef3975f17d00b4529e88366cf /configure.ac
parent0b48a9b5e05e57306d7f3a32d2be01bb352b0d18 (diff)
Handle --without-opencl-sdk or --with-opencl-sdk=no
Needed especially for OS X where building the OpenCL code is on by default, in case you still want to bypass it (if it is broken). Change-Id: I47584890869ef2b5a77e0cb68a110d49e1ff4755
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3db18131c587..3f9dbdd087b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9818,7 +9818,7 @@ if test \( -z "$with_opencl_sdk" -o "$with_opencl_sdk" = yes \) -a $_os = Darwin
OPENCL_CFLAGS=
OPENCL_LIBS="-framework OpenCL"
AC_DEFINE(HAVE_FEATURE_OPENCL)
-elif test "z$with_opencl_sdk" = "z"; then
+elif test -z "$with_opencl_sdk" -o "$with_opencl_sdk" = no; then
AC_MSG_RESULT([no])
else
if test -d "$with_opencl_sdk/include"; then