summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-10-13 11:01:41 +0200
committerSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-10-13 11:02:26 +0200
commit71586837f926c5dc7e8146a4e625b57c37343806 (patch)
tree6823b78909d4ab0b6490d0f49779cd991449e9f7 /configure.ac
parent1631fa9a722553da1ebe0650a65e859862c4405d (diff)
Emscripten has an own zlib port, use it
See https://github.com/emscripten-ports/zlib Change-Id: I0af6e2f1f1908838f940ab11706637e3407263fd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index eea4cbaf681e..eb0474360f00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7420,7 +7420,11 @@ dnl and has no pkg-config for it at least on some tinderboxes,
dnl so leaving that out for now
dnl libo_CHECK_SYSTEM_MODULE([zlib],[ZLIB],[zlib])
AC_MSG_CHECKING([which zlib to use])
-if test "$with_system_zlib" = "yes"; then
+if test "$_os" = "Emscripten"; then
+ # Emscripten provides its own zlib
+ AC_MSG_RESULT([Emscripten provided])
+ SYSTEM_ZLIB=TRUE
+elif test "$with_system_zlib" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_ZLIB=TRUE
AC_CHECK_HEADER(zlib.h, [],