summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-02-24 08:59:43 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-02-24 08:59:43 +0100
commit6502c53d5fd907fee82eb9ed58503c04739f339a (patch)
tree8f4c103b89b1faa5704df7eedbf89691ef248bd7 /configure.ac
parent6d1e22a9b8c197673f43dcb00f3270dae812c8ae (diff)
Oh, those are called Updates, not Service Packs
Change-Id: If6cfe913445e8855eab3736d9abc63d7e152b361
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 2882aecaea69..e69e9f11a6cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5519,14 +5519,14 @@ else
fi
fi
-dnl At least MSVC 2015 SP1 is known to sporadically emit warning C4592
+dnl At least MSVC 2015 Update 1 is known to sporadically emit warning C4592
dnl ("implementation limitation" when defining OUStringLiteral variables in
-dnl vcl/source/app/IconThemeInfo.cxx), while SP3 is known good, and it is
+dnl vcl/source/app/IconThemeInfo.cxx), while Update 3 is known good, and it is
dnl probably a good idea to require that anyway. A reliable way to check for
-dnl MSVC 2015 SP3 appears to be to check for support of C++17 nested namespace
-dnl definitions (which requires /std:c++latest to be enabled):
+dnl MSVC 2015 Update 3 appears to be to check for support of C++17 nested
+dnl namespace definitions (which requires /std:c++latest to be enabled):
if test "$COM" = MSC -a "$VCVER" = 140; then
- AC_MSG_CHECKING([whether MSVC 2015 compiler $MSVC_CXX is at least SP3])
+ AC_MSG_CHECKING([whether MSVC 2015 compiler $MSVC_CXX is at least Update 3])
save_CXX=$CXX
save_CXXFLAGS=$CXXFLAGS
CXX=$MSVC_CXX
@@ -5540,7 +5540,7 @@ if test "$COM" = MSC -a "$VCVER" = 140; then
CXXFLAGS=$save_CXXFLAGS
AC_MSG_RESULT([$good])
if test "$good" = no; then
- AC_MSG_ERROR([When using MSVC 2015, at least SP3 must be installed])
+ AC_MSG_ERROR([When using MSVC 2015, at least Update 3 must be installed])
fi
fi