summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-10-25 23:26:51 +0200
committerTor Lillqvist <tml@collabora.com>2020-10-26 07:31:46 +0100
commit62fa5bb8c1299469eacc21cb35ee670b65120713 (patch)
tree0a40c8a8c60316e3f0dc03ded8172f3e5e3a2648 /configure.ac
parent6cec484aeba7c08b69c11273ca9b6879609c7046 (diff)
Must use the Unix form of a pathname in a test command on WSL
(Using the Unix form doesn't hurt on Cygwin either.) Change-Id: I43c6c66feabadd9dec2287e440e5748db264fc6c Reviewed-on: https://gerrit.libreoffice.org/c/core/+/104788 Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 958a525ee737..225d56d7e406 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6158,9 +6158,10 @@ find_winsdk_version()
if test -n "$regvalue"; then
winsdkbinsubdir="$regvalue".0
winsdklibsubdir=$winsdkbinsubdir
- tmppath="$winsdktest\\Include\\$winsdklibsubdir"
+ local tmppath="$winsdktest\\Include\\$winsdklibsubdir"
+ local tmppath_unix=$(cygpath -u "$tmppath")
# test exist the SDK path
- if test -d "$tmppath"; then
+ if test -d "$tmppath_unix"; then
# when path is convertible to a short path then path is okay
cygpath -d "$tmppath" >/dev/null 2>&1
if test $? -ne 0; then