summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomáš Chvátal <tchvatal@suse.com>2018-06-06 13:48:52 +0200
committerTomáš Chvátal <tchvatal@suse.cz>2018-06-29 15:58:42 +0200
commit62bfd24503d406a2a28f03af58110a4972a5ccf2 (patch)
tree835cbc212f17af8677d82e98b21e431a5e93f07f /configure.ac
parent7f75cda91c306daa2cd8547c2ff1e4e99bacd854 (diff)
Fix calculations about version for java
This solves problem where java prints ton of warnings about too many CPUs which turned out to empty lines that are now ommited by the added sed command. Change-Id: I552f40289e1d598f11f98509b9e9b0b867336c3b Reviewed-on: https://gerrit.libreoffice.org/55377 Tested-by: Jenkins Reviewed-by: Tomáš Chvátal <tchvatal@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7848658978f2..8955729e2328 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6853,7 +6853,7 @@ you must use the "--with-jdk-home" configure option explicitly])
JDK=sun
dnl Sun JDK specific tests
- _jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED s/[[-A-Za-z]]*//`
+ _jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED '/^$/d' | $SED s/[[-A-Za-z]]*//`
_jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
if test "$_jdk_ver" -lt 10600; then