summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2020-12-13 16:01:55 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2020-12-15 11:56:11 +0100
commit591bad42866fb9beaa24f34ee746e011cba40f99 (patch)
treeafee691e1d2af4f8c4552417ed3baea971e07ab0 /configure.ac
parentcc5becc37dc4828e09f4d2f2af48b8482f7efaa3 (diff)
add a visual studio code workspace template (created by configure.ac)
Not having settings directly stored in .vscode directory in the repository/having the files ignored there is a problem when you build in a separate builddirectory and you regularly do a full reset of your sourcedir using "git clean -fdx" and similar. If you had any folder-settings, you'd lose them that way. VS Code doesn't really have a mechanism to include and then extend repository defaults, but it has three different tiers where settings are pulled from: folder, workspace and user For LibreOffice core repository there are no folder settings as our .vscode is not populated (or at least it is not stable), a user can of course place a settings.json or other configuration files in their checkout, just with the "git clean" problem mentioned above. This patch adds a workspace configuration - that file can be stored anywhere and instead references the folders to use as configuration items. If you want to add your own launch configuration or tasks: you can just store it on your desktop, and can completely wipe out your builddir as well as prune your srcdir - if you reuse the same paths for your next build, you can simply reopen that workspace file and have all your settings applied. Having it part of the core repository and created by configure from the template is thus just a convenience thing - it has a launch-in-debugger rule and settings for code search/browsing that should be all that's needed/all that's specific to LibreOffice at least. Change-Id: I8625d83d0c30c2668b99ec672c651c3d35258ca5 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107655 Reviewed-by: Ilmari Lauhakangas <ilmari.lauhakangas@libreoffice.org> Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> Tested-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d801817c36e..ad35a32c752e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13988,7 +13988,8 @@ AC_CONFIG_FILES([config_host.mk
bin/officeotron.sh
hardened_runtime.xcent
instsetoo_native/util/openoffice.lst
- sysui/desktop/macosx/Info.plist])
+ sysui/desktop/macosx/Info.plist
+ vs-code-template.code-workspace:.vscode/vs-code-template.code-workspace.in])
AC_CONFIG_HEADERS([config_host/config_buildid.h])
AC_CONFIG_HEADERS([config_host/config_box2d.h])
AC_CONFIG_HEADERS([config_host/config_clang.h])