summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2015-10-02 11:30:40 +0200
committerStephan Bergmann <sbergman@redhat.com>2015-10-02 10:07:40 +0000
commit5067d31364695d892d4290afb039a9877450fccb (patch)
tree6d82a3a28ed5fe1fd91be1d8b06c3feb18a37341 /configure.ac
parent313b82d330b5814326fb1fbb930fb09475313d85 (diff)
Remove setting Make SHELL completely from the build system
...this is a follow-up to efad388f756014a7df5ed6f8e4ce417d24e9aba9 "Clean up Make SHELL handling," which broke out-of-tree builds. There appears to be no good reason at all to fiddle with Make's own behavior of determining its SHELL variable (which defaults to /bin/sh and can be overridden via a SHELL=... command line argument when invoking Make). The SHELL_BASH fiddling in configure.ac and Makefile.in was probably cargo cult carried along ever since 815f157c05ebc20e91a050823f048a977b8ae103 "CWS-TOOLING: integrate CWS configuretoplevel," in a time when the OOo build system still defaulted to tcsh. Change-Id: If906164abb6aae649ce8088d945a40213deed361 Reviewed-on: https://gerrit.libreoffice.org/19093 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 8ab6089f7a93..e650e71531fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4519,7 +4519,6 @@ if test "$cross_compiling" = "yes"; then
lo.xcent.in \
instsetoo_native/util/openoffice.lst.in \
config_host/*.in \
- solenv/gbuild/shell.mk.in \
sysui/desktop/macosx/Info.plist.in \
ios/lo.xcconfig.in) \
| (cd CONF-FOR-BUILD && tar xf -)
@@ -4957,15 +4956,6 @@ if test "$_make_ver_check" = ""; then
STALE_MAKE=TRUE
fi
-if test -z "$SHELL_BASH"; then
- if test "$GNUMAKE_WIN_NATIVE" = "TRUE" ; then
- SHELL_BASH=$(cygpath -m $(which bash))
- else
- SHELL_BASH=`which bash`
- fi
-fi
-AC_SUBST(SHELL_BASH)
-
HAVE_LD_HASH_STYLE=FALSE
WITH_LINKER_HASH_STYLE=
AC_MSG_CHECKING( for --hash-style gcc linker support )
@@ -12998,7 +12988,6 @@ AC_CONFIG_FILES([config_host.mk
Makefile
lo.xcent
instsetoo_native/util/openoffice.lst
- solenv/gbuild/shell.mk
sysui/desktop/macosx/Info.plist
ios/lo.xcconfig])
AC_CONFIG_HEADERS([config_host/config_buildid.h])