summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-08-22 18:30:13 +0300
committerTor Lillqvist <tml@collabora.com>2014-08-22 18:57:08 +0300
commit4eaf127447189c181d3472cdb0bd0c7009ceaccc (patch)
treeb64a993479df880b5b2e66506ebb722469ce5d7d /configure.ac
parent4970d562b65d06790b816ff65daef890a7619446 (diff)
Don't add a bogus C:/cygwin64/lib/x86 (or similar) directory to ILIB
If we don't know of any separate DirectX SDK library, don't use the $DIRECTXSDK_LIB variable which is bogus at that point. Thanks to Nicholas Ferguson for noticing. Change-Id: I333478da7757694ca9236fd485e93bbd88305278
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ef3abc27db0f..370ae6e579b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12830,7 +12830,7 @@ if test "$build_os" = "cygwin"; then
fi
ILIB="$ILIB;$DOTNET_FRAMEWORK_HOME/lib"
- if test "$ENABLE_DIRECTX" = "TRUE"; then
+ if test "$ENABLE_DIRECTX" = "TRUE" -a "$HAVE_DIRECTXSDK_LIB" = "yes"; then
ILIB="$ILIB;$DIRECTXSDK_LIB"
fi
AC_SUBST(ILIB)