summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-06-07 11:37:41 +0200
committerDavid Tardon <dtardon@redhat.com>2013-06-07 11:38:41 +0200
commit49b28849e5076d5e63aab9ed50f87c61e1f43e43 (patch)
tree24d1c43b6743b568c1585ad73465bf91c952942f /configure.ac
parent042fbe97bb758282fe8b6df9ed9eac74b92c53d5 (diff)
Revert "simplify check for harfbuzz"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0be2012923ac..ff19a0d7cbec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8388,10 +8388,14 @@ AC_MSG_CHECKING([whether to enable HarfBuzz support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin"; then
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
- if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
+ if test "$with_system_harfbuzz" = "yes" -o "$with_system_libs" = "yes"; then
+ if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
+ else
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ fi
else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
fi
else
AC_MSG_RESULT([no])