summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-07-13 22:54:17 +0300
committerTor Lillqvist <tml@iki.fi>2013-07-14 09:27:55 +0300
commit46894ec48eb33dc99dab807c9fcaf0caa7c6cd84 (patch)
tree1373cf49bcd8d7e173ed87e3853bbc575a7e117b /configure.ac
parent542b45af44cae091735d9c2e11756a928e230261 (diff)
Use CL_MAP_WRITE_INVALIDATE_REGION only if defined (in OpenCL 1.2)
Can again turn on OpenCL by default for OS X then, hopefully. Change-Id: Id84b2c17c8431080261be45923d8c153f3822e8b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 6f5fe8dd611d..cc439e08a9a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9811,15 +9811,14 @@ OPENCL_LIBS=
OPENCL_CFLAGS=
ENABLE_OPENCL=
AC_MSG_CHECKING([OpenCL])
-dnl if test \( -z "$with_opencl_sdk" -o "$with_opencl_sdk" = yes \) -a $_os = Darwin; then
-dnl # OS X
-dnl AC_MSG_RESULT([yes, always on OS X])
-dnl ENABLE_OPENCL=TRUE
-dnl OPENCL_CFLAGS=
-dnl OPENCL_LIBS="-framework OpenCL"
-dnl AC_DEFINE(HAVE_FEATURE_OPENCL)
-dnl
-if test -z "$with_opencl_sdk" -o "$with_opencl_sdk" = no; then
+if test \( -z "$with_opencl_sdk" -o "$with_opencl_sdk" = yes \) -a $_os = Darwin; then
+ # OS X
+ AC_MSG_RESULT([yes, always on OS X])
+ ENABLE_OPENCL=TRUE
+ OPENCL_CFLAGS=
+ OPENCL_LIBS="-framework OpenCL"
+ AC_DEFINE(HAVE_FEATURE_OPENCL)
+elif test -z "$with_opencl_sdk" -o "$with_opencl_sdk" = no; then
AC_MSG_RESULT([no])
else
if test -d "$with_opencl_sdk/include"; then