summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2013-05-29 12:08:31 +0100
committerMichael Meeks <michael.meeks@suse.com>2013-07-26 10:50:16 +0100
commit4426b03a38279c99857202871917a5b9cef02758 (patch)
tree31b73f5d3917ee854807a707a6d7a3cea147c723 /configure.ac
parent60c19683b5897beefa0e799b7efdc3e2b4da528e (diff)
initial configure pieces for VLC detection.
Change-Id: I1001d7f87c3e3194c04ea9d1ef97a87898f891ea
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b45b175288c4..9eb04ea4a61e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1015,6 +1015,11 @@ AC_ARG_ENABLE(gstreamer-0-10,
[Disable building the gstreamer avmedia backend.]),
,enable_gstreamer_0_10=yes)
+AC_ARG_ENABLE(vlc,
+ AS_HELP_STRING([--enable-vlc],
+ [Enable building with the VLC avmedia backend.]),
+,enable_vlc=no)
+
AC_ARG_ENABLE(neon,
AS_HELP_STRING([--disable-neon],
[Disable neon and the compilation of webdav binding.]),
@@ -9910,6 +9915,27 @@ AC_SUBST(GSTREAMER_0_10_LIBS)
AC_SUBST(ENABLE_GSTREAMER_0_10)
dnl ===================================================================
+dnl Check whether the VLC libraries are available.
+dnl ===================================================================
+
+ENABLE_VLC=""
+
+if test "$build_gstreamer" = "yes"; then
+
+ AC_MSG_CHECKING([whether to enable the new VLC avmedia backend])
+ if test "x$enable_vlc" != "xno"; then
+ ENABLE_VLC="TRUE"
+ AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES( VLC, libvlc >= 2.0.0 )
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST(VLC_CFLAGS)
+AC_SUBST(VLC_LIBS)
+AC_SUBST(ENABLE_VLC)
+
+dnl ===================================================================
dnl Check whether the OpenGL libraries are available
dnl ===================================================================