summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-10-25 23:30:11 +0200
committerTor Lillqvist <tml@collabora.com>2020-10-26 07:28:35 +0100
commit3e9620707a029720ce7b293206961c5e73f1565f (patch)
tree7db2aeb17db66a14c4c08503175e9ac71a52b716 /configure.ac
parent4afe501d99b476292cf8bf3ed15a7e4c4894ad9d (diff)
Make more of the Windows SDK checks work on WSL
Part of work in progress. Committing in smaller bits to make potential bisecting easier. Change-Id: I604bdd993288369051b3365014be54090f987559 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/104789 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 31ec94fb9856..958a525ee737 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6304,7 +6304,7 @@ dnl Check for the Windows SDK.
dnl =========================================
if test "$_os" = "WINNT"; then
AC_MSG_CHECKING([for Windows SDK])
- if test "$build_os" = "cygwin"; then
+ if test "$build_os" = "cygwin" -o "$build_os" = "wsl"; then
find_winsdk
WINDOWS_SDK_HOME=$winsdktest
@@ -6367,7 +6367,8 @@ the Windows SDK are installed.])
fi
PathFormat "$WINDOWS_SDK_HOME"
WINDOWS_SDK_HOME="$formatted_path"
- if test "$build_os" = "cygwin"; then
+ WINDOWS_SDK_HOME_unix="$formatted_path_unix"
+ if test "$build_os" = "cygwin" -o "$build_os" = "wsl"; then
SOLARINC="$SOLARINC -I$WINDOWS_SDK_HOME/include -I$COMPATH/Include"
if test -d "$WINDOWS_SDK_HOME/include/um"; then
SOLARINC="$SOLARINC -I$WINDOWS_SDK_HOME/include/um -I$WINDOWS_SDK_HOME/include/shared"
@@ -6385,21 +6386,25 @@ the Windows SDK are installed.])
dnl msiglobal.pm:
if test -z "$WINDOWS_SDK_WILANGID" -a -n "$WINDOWS_SDK_HOME"; then
WINDOWS_SDK_WILANGID=$WINDOWS_SDK_HOME/Samples/sysmgmt/msi/scripts/WiLangId.vbs
- if ! test -e "$WINDOWS_SDK_WILANGID" ; then
+ WINDOWS_SDK_WILANGID_unix=$(cygpath -u "$WINDOWS_SDK_WILANGID")
+ if ! test -e "$WINDOWS_SDK_WILANGID_unix" ; then
WINDOWS_SDK_WILANGID="${WINDOWS_SDK_HOME}/bin/${WINDOWS_SDK_LIB_SUBDIR}/${WIN_BUILD_ARCH}/WiLangId.vbs"
+ WINDOWS_SDK_WILANGID_unix=$(cygpath -u "$WINDOWS_SDK_WILANGID")
fi
- if ! test -e "$WINDOWS_SDK_WILANGID" ; then
+ if ! test -e "$WINDOWS_SDK_WILANGID_unix" ; then
WINDOWS_SDK_WILANGID=$WINDOWS_SDK_HOME/bin/$WIN_BUILD_ARCH/WiLangId.vbs
+ WINDOWS_SDK_WILANGID_unix=$(cygpath -u "$WINDOWS_SDK_WILANGID")
fi
- if ! test -e "$WINDOWS_SDK_WILANGID" ; then
+ if ! test -e "$WINDOWS_SDK_WILANGID_unix" ; then
WINDOWS_SDK_WILANGID=$(cygpath -sm "C:/Program Files (x86)/Windows Kits/8.1/bin/$WIN_BUILD_ARCH/WiLangId.vbs")
+ WINDOWS_SDK_WILANGID_unix=$(cygpath -u "$WINDOWS_SDK_WILANGID")
fi
fi
if test -n "$with_lang" -a "$with_lang" != "en-US"; then
if test -n "$with_package_format" -a "$with_package_format" != no; then
for i in "$with_package_format"; do
if test "$i" = "msi"; then
- if ! test -e "$WINDOWS_SDK_WILANGID" ; then
+ if ! test -e "$WINDOWS_SDK_WILANGID_unix" ; then
AC_MSG_ERROR([WiLangId.vbs not found - building translated packages will fail])
fi
fi