summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-05-31 13:10:44 +0200
committerMichael Stahl <mstahl@redhat.com>2013-06-04 12:00:57 +0200
commit3d9c1b35accacfb797174d31467c1704c305f073 (patch)
treecece7ceb73e68117899c685caa0fbd26ca436a00 /configure.ac
parent8b43736ca7eba8a9bf0b2421e267a987e5fdf209 (diff)
configure: require doxygen 1.8.4 for UNO IDL support
Change-Id: I9a90bf06a70f6537f9671ef2cd47bf68c3cf5d57
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b55b68b61f98..8fffad953b70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6965,6 +6965,11 @@ else
DOXYGEN=$with_doxygen
AC_MSG_RESULT([$DOXYGEN])
fi
+ DOXYGEN_VERSION=`$DOXYGEN --version 2>/dev/null`
+ DOXYGEN_NUMVERSION=`echo $DOXYGEN_VERSION | $AWK -F. '{ print \$1*10000 + \$2*100 + \$3 }'`
+ if ! test "$DOXYGEN_NUMVERSION" -ge "10804" ; then
+ AC_MSG_ERROR([found doxygen is too old; need at least version 1.8.4 or specify --without-doxygen])
+ fi
fi
fi
AC_SUBST([DOXYGEN])