summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-11-20 16:55:17 +0200
committerTor Lillqvist <tml@collabora.com>2014-11-20 16:56:40 +0200
commit3b0b76462aa54f60bc9823d9c6ef64e5e35c1208 (patch)
tree5f26a419a009d113734ec9987f9c430490cfcc41 /configure.ac
parent3889cc44f4bbfcd7e07259575e092288aa987e9e (diff)
No need to have OpenCL optional at configure-time
It continues to not be used on platforms where not available (iOS and Android), and on others it is optional at run-time anyway. Change-Id: I7ba2f87ac143aad78df7edc2e6e6dc014c29c071
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index e716ad011533..310bb9cd2dd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1106,10 +1106,6 @@ AC_ARG_ENABLE(opengl,
AS_HELP_STRING([--disable-opengl],
[Determines whether to build the OpenGL 3D slide transitions and canvas component.]))
-AC_ARG_ENABLE(opencl,
- AS_HELP_STRING([--disable-opencl],
- [Determines whether to build with OpenCL support.]))
-
AC_ARG_ENABLE(dbus,
AS_HELP_STRING([--disable-dbus],
[Determines whether to enable features that depend on dbus.
@@ -10314,17 +10310,11 @@ dnl =================================================
dnl Check whether to build with OpenCL support.
dnl =================================================
-AC_MSG_CHECKING([whether to build with the OpenCL support.])
ENABLE_OPENCL=
-
-if test $_os != iOS -a $_os != Android -a "x$enable_opencl" != "xno"; then
- AC_MSG_RESULT([yes])
+if test $_os != iOS -a $_os != Android; then
ENABLE_OPENCL=TRUE
AC_DEFINE(HAVE_FEATURE_OPENCL)
-else
- AC_MSG_RESULT([no])
fi
-
AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================