summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-06-07 10:40:54 +0200
committerDavid Tardon <dtardon@redhat.com>2013-06-07 10:42:39 +0200
commit36edf2e6fff430beeb35882b408ceb01453a9e18 (patch)
tree276c12dfa26d86d6cd1b2ddd599a5412c50df5a9 /configure.ac
parent8fd28fe7373fcdf17c061c3666b6012445e3bfc3 (diff)
simplify check for harfbuzz
We check for it in both branches of the if, right? So why do not drop it entirely? Change-Id: I715bfb55c02c5425bbb4874b97aca9d2872acced
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index ff19a0d7cbec..0be2012923ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8388,14 +8388,10 @@ AC_MSG_CHECKING([whether to enable HarfBuzz support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin"; then
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
- if test "$with_system_harfbuzz" = "yes" -o "$with_system_libs" = "yes"; then
- if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
- else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
- fi
+ if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
fi
else
AC_MSG_RESULT([no])