summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2015-10-10 17:30:27 +0200
committerRene Engelhard <rene@debian.org>2015-10-10 17:31:36 +0200
commit34433196114f91af7216fe03823d2d0e920750bd (patch)
treed9db55cbd3bfd8a2161309b5715df160bb6a9ba5 /configure.ac
parent82cf6c67373290c65523431e845d00c67f08be42 (diff)
add "GODSON64" aka mips64 to the JAVAINTERPRETER 64bit check
Change-Id: I20aa0e6cea6626efb5f507a6dbbfb7e6149029ce
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dc6def330127..fd9c75559621 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6829,7 +6829,7 @@ if test "$ENABLE_JAVA" != ""; then
JAVAINTERPRETER=`win_short_path_for_make "$JAVAINTERPRETER"`
elif test "$cross_compiling" != "yes"; then
case $CPUNAME in
- AARCH64|AXP|X86_64|HPPA|IA64|POWERPC64|S390X|SPARC64)
+ AARCH64|AXP|X86_64|HPPA|IA64|POWERPC64|S390X|SPARC64|GODSON64)
if test -f "$JAVAINTERPRETER" -a "`$JAVAINTERPRETER -version 2>&1 | $GREP -i 64-bit`" = "" >/dev/null; then
AC_MSG_WARN([You are building 64-bit binaries but the JDK $JAVAINTERPRETER is 32-bit])
AC_MSG_ERROR([You should pass the --with-jdk-home option pointing to a 64-bit JDK])