summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-09-16 17:03:17 +0200
committerSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-10-05 10:24:35 +0000
commit338f19a8cecfa632fa23d42cc27769a832d62104 (patch)
tree32a9f5f89828a35e4c59c9fddab7da44bea8eeb6 /configure.ac
parente62c2b03c79cf00c7bb7f08e986f73c76b784581 (diff)
Emscripten: First steps of porting to Emscripten
See https://wiki.documentfoundation.org/Development/Emscripten for details Change-Id: I977a8b9e98b9be13c263fef48f567b92347d0492 Reviewed-on: https://gerrit.libreoffice.org/18643 Reviewed-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de> Tested-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 34 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c19924834025..8554d05a8567 100644
--- a/configure.ac
+++ b/configure.ac
@@ -814,6 +814,27 @@ linux-android*)
BUILD_TYPE="$BUILD_TYPE FONTCONFIG FREETYPE"
;;
+emscripten*)
+ build_gstreamer_1_0=no
+ build_gstreamer_0_10=no
+ enable_lotuswordpro=no
+ enable_mpl_subset=yes
+ enable_coinmp=yes
+ enable_lpsolve=no
+ enable_report_builder=no
+ with_theme="tango"
+ test_cups=no
+ test_dbus=no
+ test_fontconfig=no
+ test_freetype=no
+ test_gtk=no
+ test_tde=no
+ test_kde4=no
+ test_randr=no
+ test_xrender=no
+ _os=Emscripten
+ ;;
+
*)
AC_MSG_ERROR([$host_os operating system is not suitable to build LibreOffice for!])
;;
@@ -4313,6 +4334,17 @@ linux-android*)
esac
;;
+emscripten*)
+ COM=emcc
+ USING_X11=
+ OS=EMSCRIPTEN
+ RTL_OS=Emscripten
+ P_SEP=:
+ CPUNAME=INTEL
+ RTL_ARCH=x86
+ PLATFORMID=linux_x86
+ ;;
+
mingw*)
COM=GCC
USING_X11=
@@ -5376,7 +5408,7 @@ else
fi
dnl check for GNU C++ compiler version
-if test "$GXX" = "yes"; then
+if test "$GXX" = "yes" -a $CXX != "emcc"; then
AC_MSG_CHECKING([the GNU C++ compiler version])
_gpp_version=`$CXX -dumpversion`
@@ -10067,7 +10099,7 @@ fi
AC_SUBST(ENABLE_KDE4)
ENABLE_HEADLESS=""
-if test "x$with_x" = "xno"; then
+if test "x$with_x" = "xno" -o $CXX = "emcc"; then
ENABLE_HEADLESS="TRUE"
SCPDEFS="$SCPDEFS -DLIBO_HEADLESS"
R="headless"