summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noelgrandin@gmail.com>2018-08-26 17:22:56 +0200
committerNoel Grandin <noel.grandin@collabora.co.uk>2018-08-27 08:47:49 +0200
commit2b5812e0191d43bff939274d88e7ec3ce02ce6cd (patch)
treef360e4740c06eb0d1fc33d3e087e578fcaf760e0 /configure.ac
parente6f4779de8fea16931967ce206439c5780d46125 (diff)
rename ENABLE_HEADLESS option to DISABLE_GUI
since it has nothing to do with the headless command line option, so use the name it has in the configure.ac file Change-Id: Ibf0615ed02695d6e48a797f5632e4f417c010c70 Reviewed-on: https://gerrit.libreoffice.org/59611 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 46758b51037d..85315fa473a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4413,17 +4413,17 @@ if test "$with_x" = "no"; then
AC_MSG_ERROR([Use --disable-gui instead. How can we get rid of this option? No idea where it comes from.])
fi
-ENABLE_HEADLESS=""
+DISABLE_GUI=""
if test "$enable_gui" = "no"; then
if test "$USING_X11" != TRUE; then
AC_MSG_ERROR([$host_os operating system is not suitable to build LibreOffice with --disable-gui.])
fi
USING_X11=
- ENABLE_HEADLESS=TRUE
+ DISABLE_GUI=TRUE
AC_DEFINE(HAVE_FEATURE_UI,0)
test_cairo=yes
fi
-AC_SUBST(ENABLE_HEADLESS)
+AC_SUBST(DISABLE_GUI)
WORKDIR="${BUILDDIR}/workdir"
INSTDIR="${BUILDDIR}/instdir"