summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-12-13 09:43:55 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-12-13 13:29:40 +0100
commit25a0ae6138d5439bf0c1490be2e667a8e7b4beec (patch)
treed494039629d1685132d5be67a89be43da62af739 /configure.ac
parent868a683138308727496f53b43aa145a0a4e03c83 (diff)
Introduce --enable-android-editing
...to select the experimental ...Editing... Android build variant. (Ignored for non-Android builds, but using libo_FUZZ_ARG_ENABLE anyway, just in case.) Change-Id: I670925ff358039e38edc29db69f48a78d484f133 Reviewed-on: https://gerrit.libreoffice.org/65077 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14182d154939..e30d0cc938b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -526,6 +526,16 @@ if test -n "$with_android_sdk"; then
fi
AC_SUBST(ANDROID_SDK_HOME)
+libo_FUZZ_ARG_ENABLE([android-editing],
+ AS_HELP_STRING([--enable-android-editing],
+ [Enable the experimental editing feature on Android.])
+)
+ENABLE_ANDROID_EDITING=
+if test "$enable_android_editing" = yes; then
+ ENABLE_ANDROID_EDITING=TRUE
+fi
+AC_SUBST([ENABLE_ANDROID_EDITING])
+
dnl ===================================================================
dnl The following is a list of supported systems.
dnl Sequential to keep the logic very simple