summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2013-06-23 23:37:01 +0200
committerLionel Elie Mamane <lionel@mamane.lu>2013-06-23 23:37:01 +0200
commit214e1c17e712cc5d27743c5f8e9d5f05c14ee8bd (patch)
tree78b43865993bd4dfef4ce21ce561c82633cddfb8 /configure.ac
parent88c1756f1714af773129514d44c84cb7dbd7ee18 (diff)
Complain about too old doxygen only when there is one
Change-Id: I6c460375945eac8dccddca196f67b8d224e0d34e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b9810f36f2e0..765bf72bd1b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7147,10 +7147,12 @@ else
DOXYGEN=$with_doxygen
AC_MSG_RESULT([$DOXYGEN])
fi
- DOXYGEN_VERSION=`$DOXYGEN --version 2>/dev/null`
- DOXYGEN_NUMVERSION=`echo $DOXYGEN_VERSION | $AWK -F. '{ print \$1*10000 + \$2*100 + \$3 }'`
- if ! test "$DOXYGEN_NUMVERSION" -ge "10804" ; then
- AC_MSG_ERROR([found doxygen is too old; need at least version 1.8.4 or specify --without-doxygen])
+ if test -n "$DOXYGEN"; then
+ DOXYGEN_VERSION=`$DOXYGEN --version 2>/dev/null`
+ DOXYGEN_NUMVERSION=`echo $DOXYGEN_VERSION | $AWK -F. '{ print \$1*10000 + \$2*100 + \$3 }'`
+ if ! test "$DOXYGEN_NUMVERSION" -ge "10804" ; then
+ AC_MSG_ERROR([found doxygen is too old; need at least version 1.8.4 or specify --without-doxygen])
+ fi
fi
fi
fi