summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@pefoley.com>2014-09-07 21:07:43 -0400
committerDavid Tardon <dtardon@redhat.com>2014-09-08 03:17:47 -0500
commit2114e88fc69c6c650ebe1a390de6117d58b10716 (patch)
treefe141278c935aa859075d5d50d47634ade70625f /configure.ac
parent513a3a6a01679046d354f9acc75d98d9e97979db (diff)
Make configure respect --without-system-$lib-for-build
Change-Id: I64cb58e7980de8fdb23f5c0efa75c05a1f0aa904 Reviewed-on: https://gerrit.libreoffice.org/11330 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 897cb1e0ede5..2ec22264a8d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4705,11 +4705,11 @@ if test "$cross_compiling" = "yes"; then
test -n "$with_ant_home" && sub_conf_opts="$sub_conf_opts --with-ant-home=$with_ant_home"
test $with_junit = no && sub_conf_opts="$sub_conf_opts --without-junit"
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
- test -n "$with_system_boost_for_build" && sub_conf_opts="$sub_conf_opts --with-system-boost"
- test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit"
- test -n "$with_system_expat_for_build" && sub_conf_opts="$sub_conf_opts --with-system-expat"
+ test -n "$with_system_boost_for_build" && sub_conf_opts="$sub_conf_opts --with-system-boost=$with_system_boost_for_build"
+ test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit=$with_system_cppunit_for_build"
+ test -n "$with_system_expat_for_build" && sub_conf_opts="$sub_conf_opts --with-system-expat=$with_system_expat_for_build"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
- test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
+ test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml=$with_system_libxml_for_build"
# we need the msi build tools on mingw if we are creating the
# installation set
if test "$WITH_MINGW" = "yes"; then