summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-05-13 18:15:48 +0300
committerTor Lillqvist <tml@collabora.com>2020-05-18 08:07:43 +0200
commit1f6b7678d52e1bf9092e3ce2cf7b7c4ffdcb2ba2 (patch)
treec9554fbc4d2281a9c587ec88fc0e3be4d0fce61f /configure.ac
parent557c6777ad33b54af28541a96bcf91596995b388 (diff)
I am told we don't want to use old style help files any longer
Make --with-help mean the same as --with-help=html to avoid generating such unintentionally. Change-Id: Ie53b3604f53c3301cb196b2239dce6f0c08acbd3 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/94145 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1d531f32edec..171dd945a241 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2021,7 +2021,7 @@ AC_ARG_WITH(help,
can be used to bundle only the common part, .e.g help-specific icons.
This is useful when you build the helpcontent separately.])
[
- Usage: --with-help build the old local help
+ Usage: --with-help build the new HTML local help
--without-help no local help (default)
--with-help=html build the new HTML local help
--with-help=online build the new HTML online help
@@ -5049,8 +5049,9 @@ if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Androi
AC_MSG_RESULT([HTML])
;;
yes)
+ ENABLE_HTMLHELP=TRUE
SCPDEFS="$SCPDEFS -DWITH_HELP"
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([HTML])
;;
*)
AC_MSG_ERROR([Unknown --with-help=$with_help])