summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2013-05-16 21:56:04 +0100
committerMichael Meeks <michael.meeks@suse.com>2013-06-03 11:41:36 +0100
commit1e4422a4b4c443c286c90853f50b739a67ce5d1f (patch)
treed09d18435b1c7f579fed91e48927c29af4239d19 /configure.ac
parente89ab73fa01e825bd55908c9ba3697cb00cead16 (diff)
re-base on ALv2 code. Includes:
Patches contributed by Mathias Bauer gnumake4 work variously http://svn.apache.org/viewvc?view=revision&revision=1394707 http://svn.apache.org/viewvc?view=revision&revision=1394326 http://svn.apache.org/viewvc?view=revision&revision=1397337 http://svn.apache.org/viewvc?view=revision&revision=1397315 http://svn.apache.org/viewvc?view=revision&revision=1396797 Patches contributed by Andre Fischer Fixed getcsym.awk to handle #-comments that contain special regexp chars. http://svn.apache.org/viewvc?view=revision&revision=1230971 118778: Added ADDITIONAL_REPOSITORIES environment variable and its automatic setup in configure. http://svn.apache.org/viewvc?view=revision&revision=1232004 118160: Added external CoinMP library. http://svn.apache.org/viewvc?view=revision&revision=1233909 Patches contributed by Herbert Duerr #i119168# use generic LICENSE file for langpacks and sdks http://svn.apache.org/viewvc?view=revision&revision=1310178 macosxotoolhelper: need to quote perl regexp if it may contain regexp metachars http://svn.apache.org/viewvc?view=revision&revision=1183367 allow gbuild with empty sysroot on linux http://svn.apache.org/viewvc?view=revision&revision=1179186 Patches contributed by Ingo Schmidt native373: #164472# improvements for msi database http://svn.apache.org/viewvc?view=revision&revision=1167540 http://svn.apache.org/viewvc?view=revision&revision=1167539 Patches contributed by Jurgen Schmidt adapt setup package scripts to handle special DS_Store file for developer snapshot builds http://svn.apache.org/viewvc?view=revision&revision=1232430 imported patch extensions_i117681.patch http://svn.apache.org/viewvc?view=revision&revision=1172102 Patches contributed by Michael Stahl gbuild: RepositoryFixes.mk should be optional http://svn.apache.org/viewvc?view=revision&revision=1166123 xslt filter: remove the FLA horror wordml import filter: replace FLA usage with plain XSLT http://svn.apache.org/viewvc?view=revision&revision=1363727 Patch contributed by Oliver-Rainer Wittmann i#88652: applied patch, remove unicows deps http://svn.apache.org/viewvc?view=revision&revision=1177585 Remove lots of OS2 conditionals, re-extract Rhino Java, unwind cppunit pieces, cleanup Mac image bits, remove coin-mp and re-package lpsolve, Oxygen & Crystal, fixup qstart bits, expand MPLv2 subset checking. Change-Id: Iad5c8a76399620b892671633c0d8c29996db3564
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac61
1 files changed, 38 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 6bf8c1f3f3de..b55b68b61f98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6925,28 +6925,6 @@ if test "$enable_lotuswordpro" = "yes"; then
fi
AC_SUBST(ENABLE_LWP)
-AC_MSG_CHECKING([MPL subset])
-MPL_SUBSET=
-
-if test "$enable_mpl_subset" = "yes"; then
- if test "x$enable_postgresql_sdbc" != "xno"; then
- AC_MSG_ERROR([need to --disable-postgresql-sdbc - the postgress database backend.])
- fi
- if test "$enable_lotuswordpro" = "yes"; then
- AC_MSG_ERROR([need to --disable-lotuswordpro - a Lotus Word Pro file format import filter.])
- fi
- if test "$enable_neon" != "no"; then
- AC_MSG_ERROR([need to --disable-neon - webdav support.])
- fi
-
- MPL_SUBSET="TRUE"
- AC_DEFINE(MPL_HAVE_SUBSET)
- AC_MSG_RESULT([only])
-else
- AC_MSG_RESULT([no restrictions])
-fi
-AC_SUBST(MPL_SUBSET)
-
dnl ===================================================================
dnl Check for gperf
dnl ===================================================================
@@ -8403,7 +8381,7 @@ dnl ===================================================================
dnl Check for NPAPI interface to plug browser plugins into LibreOffice documents
dnl ===================================================================
AC_MSG_CHECKING([whether to plug browser plugins into LibreOffice documents])
-# Obviously no such thing on iOS or Android. Also not possible when building
+# Obviously no such thing on iOS or Android. Also not possible when building
# 64-bit OS X code as the plugin code uses QuickTime and Carbon.
if test "$_os" != Android -a "$_os" != iOS -a \( $_os != Darwin -o "$BITNESS_OVERRIDE" = "" \) -a \
"$enable_headless" != yes
@@ -11713,6 +11691,43 @@ fi
AC_SUBST(ICECREAM_RUN)
dnl ===================================================================
+
+AC_MSG_CHECKING([MPL subset])
+MPL_SUBSET=
+
+if test "$enable_mpl_subset" = "yes"; then
+ if test "x$enable_postgresql_sdbc" != "xno"; then
+ AC_MSG_ERROR([need to --disable-postgresql-sdbc - the postgress database backend.])
+ fi
+ if test "$enable_lotuswordpro" = "yes"; then
+ AC_MSG_ERROR([need to --disable-lotuswordpro - a Lotus Word Pro file format import filter.])
+ fi
+ if test "$enable_neon" != "no"; then
+ AC_MSG_ERROR([need to --disable-neon - webdav support.])
+ fi
+ if test "x$enable_ext_mariadb_connector" = "xyes"; then
+ AC_MSG_ERROR([need to --disable-ext-mariadb-connector - mariadb/mysql support.])
+ fi
+ if test "x$ENABLE_PDFIMPORT" != "xFALSE"; then
+ if test "x$SYSTEM_POPPLER" != "xNO"; then
+ AC_MSG_ERROR([need to disable PDF import via xpdf/poplar or use system library])
+ fi
+ fi
+ # cf. m4/libo_check_extension.m4
+ if test "x$WITH_EXTRA_EXTENSIONS" != "x"; then
+ AC_MSG_ERROR([need to disable extra extensions '$WITH_EXTRA_EXTENSIONS'])
+ fi
+
+ MPL_SUBSET="TRUE"
+ AC_DEFINE(MPL_HAVE_SUBSET)
+ AC_MSG_RESULT([only])
+else
+ AC_MSG_RESULT([no restrictions])
+fi
+AC_SUBST(MPL_SUBSET)
+
+
+dnl ===================================================================
dnl Setting up the environment.
dnl ===================================================================
echo "setting up the build environment variables..."