summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-08-06 16:23:03 +0300
committerTor Lillqvist <tml@collabora.com>2020-08-07 11:34:28 +0200
commit1cee06c080bceab86ac894f8ae86d4d296b050aa (patch)
treeced2f7d47171831982d1bdf801a1c61221a48fc0 /configure.ac
parent12d24634dfbe6c191c810a0d2be53211cb86c75f (diff)
Update config.{guess,sub} with latest versions and handle fallout of that
From http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD and http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD . This time, do not apply the add-on change from 25a09c8776cc6088a5b2bf13dc84eb386c26bb7e to config.sub, but keep it pristine. Instead, let's start using the name "aarch64" instead of "arm64" for macOS and iOS in the autofoo context, as that is what those tools call it. Clang and Apple call it arm64, though. Change-Id: I1e05866c5fb08e0800cdfeaf7f6a71bfb43d1777 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/100272 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 29 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 08b0d7f037fd..d39770fcc007 100644
--- a/configure.ac
+++ b/configure.ac
@@ -599,6 +599,8 @@ SDKDIRNAME=sdk
HOST_PLATFORM="$host"
+host_cpu_for_clang="$host_cpu"
+
case "$host_os" in
solaris*)
@@ -701,11 +703,19 @@ darwin*|macos*) # macOS
# -undefined error is the default
LINKFLAGSNOUNDEFS=""
- if test "$host_cpu" = arm64; then
- # HOST_PLATFORM is used for external projects and their configury occasionally doesn't like
- # the "macos" part so be sure to use arm64-apple-darwin for now.
- HOST_PLATFORM=arm64-apple-darwin
- fi
+ case "$host_cpu" in
+ aarch64|arm64)
+ case "$host_os" in
+ macos*)
+ # HOST_PLATFORM is used for external projects and their configury occasionally doesn't like
+ # the "macos" part so be sure to use aarch64-apple-darwin for now.
+ HOST_PLATFORM=aarch64-apple-darwin
+ ;;
+ esac
+
+ # Apple's Clang uses "arm64"
+ host_cpu_for_clang=arm64
+ esac
;;
ios*) # iOS
@@ -743,9 +753,12 @@ ios*) # iOS
# -undefined error is the default
LINKFLAGSNOUNDEFS=""
- # HOST_PLATFORM is used for external projects and their configury typically doesn't like the "ios" part,
- # so use arm64-apple-darwin as before for now.
- HOST_PLATFORM=arm64-apple-darwin
+ # HOST_PLATFORM is used for external projects and their configury typically doesn't like the "ios"
+ # part, so use aarch64-apple-darwin for now.
+ HOST_PLATFORM=aarch64-apple-darwin
+
+ # Apple's Clang uses "arm64"
+ host_cpu_for_clang=arm64
;;
freebsd*)
@@ -3155,13 +3168,13 @@ if test $_os = iOS; then
AC_MSG_CHECKING([what C compiler to use])
CC="`xcrun -find clang`"
CC_BASE=`first_arg_basename "$CC"`
- CC+=" -arch $host_cpu -isysroot $sysroot $lto $versionmin"
+ CC+=" -arch $host_cpu_for_clang -isysroot $sysroot $lto $versionmin"
AC_MSG_RESULT([$CC])
AC_MSG_CHECKING([what C++ compiler to use])
CXX="`xcrun -find clang++`"
CXX_BASE=`first_arg_basename "$CXX"`
- CXX+=" -arch $host_cpu $stdlib -isysroot $sysroot $lto $versionmin"
+ CXX+=" -arch $host_cpu_for_clang $stdlib -isysroot $sysroot $lto $versionmin"
AC_MSG_RESULT([$CXX])
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
@@ -4347,12 +4360,12 @@ darwin*|macos*)
P_SEP=:
case "$host_cpu" in
- arm64)
+ aarch64|arm64)
if test "$enable_ios_simulator" = "yes"; then
OS=iOS
else
- CPUNAME=ARM64
- RTL_ARCH=AARCH
+ CPUNAME=AARCH64
+ RTL_ARCH=AARCH64
PLATFORMID=macosx_arm64
fi
;;
@@ -4378,7 +4391,7 @@ ios*)
P_SEP=:
case "$host_cpu" in
- arm64)
+ aarch64|arm64)
if test "$enable_ios_simulator" = "yes"; then
AC_MSG_ERROR([iOS simulator is only available in macOS not iOS])
fi
@@ -4387,8 +4400,8 @@ ios*)
AC_MSG_ERROR([Unsupported host_cpu $host_cpu for host_os $host_os])
;;
esac
- CPUNAME=ARM64
- RTL_ARCH=ARM_EABI
+ CPUNAME=AARCH64
+ RTL_ARCH=AARCH64
PLATFORMID=ios_arm64
;;