summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2015-07-26 21:38:38 +0200
committerMichael Stahl <mstahl@redhat.com>2015-10-25 08:29:39 +0000
commit147cb6a2ae63debed3dd500e19b2776cebbc0031 (patch)
tree79c23c3ee4c0dde4cb5e17b025d0fabd55bf0243 /configure.ac
parent1a4fc613e13d2ac3cf9cf96f29aa3f367a8fb25a (diff)
Bump python to 3.5
3.5 release is needed for MSVC 14.0 (aka VS 2015) support. Python 3.5 removed build toolchain support for MSVC 2013. Because we still need to support it, we duplicate the Python directory in externals and copy old patches and dispatch to this directory for MSVC 2013. Once the support for MSVC 2013 is dropped on master, this directory can be removed again. Change-Id: Idf7bc351239582f583ecbdb53c923cbdcf968089 Reviewed-on: https://gerrit.libreoffice.org/17352 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cd3b983cd3e6..7f81a2e71b4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8055,8 +8055,15 @@ int main(int argc, char **argv) {
internal)
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
- PYTHON_VERSION_MINOR=3
- PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.5
+ # On windows we are supporting two different python versions: 3.3 and 3.5.
+ # We msut do it as long as we support MSVC 2013. Python 3.3 can be removed
+ # when MSVC 2013 support was dropped.
+ if test "$COM" = "MSC" -a $VCVER = 120; then
+ PYTHON_VERSION_MINOR=3
+ else
+ PYTHON_VERSION_MINOR=5
+ fi
+ PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.0
AC_DEFINE_UNQUOTED([PYTHON_VERSION_STRING], [L"${PYTHON_VERSION}"])
BUILD_TYPE="$BUILD_TYPE PYTHON"
# Embedded Python dies without Home set