summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2020-07-05 18:53:20 +0300
committerTor Lillqvist <tml@collabora.com>2020-07-06 10:12:40 +0200
commit0a08f981a6de90f9b9b7b75dc79d5e9b8b6e2707 (patch)
tree332a4053b9d01b79e4d66419978354886d5624d8 /configure.ac
parentdc7e7b94a7211c576454267c09eb108e761e4487 (diff)
Allow also --disable-python on macOS
Change-Id: I27cdd86a730a042d6e846c90319c306f5a3b35ad Reviewed-on: https://gerrit.libreoffice.org/c/core/+/98159 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index efe8fb83b67b..cd1e6a52c615 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8839,8 +8839,8 @@ AC_SUBST(XMLLINT)
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
-if test $_os = Darwin -a "$enable_python" != fully-internal -a "$enable_python" != internal; then
- # Only allowed choices for macOS are 'internal' (default) and 'fully-internal'
+if test $_os = Darwin -a "$enable_python" != no -a "$enable_python" != fully-internal -a "$enable_python" != internal; then
+ # Only allowed choices for macOS are 'no', 'internal' (default), and 'fully-internal'
enable_python=internal
fi
if test "$build_os" != "cygwin" -a "$enable_python" != fully-internal; then