summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2013-11-02 11:01:44 +0100
committerMichael Meeks <michael.meeks@collabora.com>2013-11-19 10:02:23 +0000
commitb4f2dc2b6470b46c6eed521dd1632f48c1f43afd (patch)
tree446091ff6ef843565ae7981b4e25629865a526e3 /configure.ac
parentcd44cc1d2249062fb68b063a0efdf3542124dcaa (diff)
Add --enable-ia2 configuration option
Change-Id: I950c47bd95d5bb4aacf9e584c8e2eeef461af71f
Diffstat (limited to 'configure.ac')
-rwxr-xr-x[-rw-r--r--]configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44dcde816d41..b75be239292f 100644..100755
--- a/configure.ac
+++ b/configure.ac
@@ -1308,6 +1308,11 @@ AC_ARG_ENABLE(library-bin-tar,
for the next time.]),
)
+AC_ARG_ENABLE(ia2,
+ AS_HELP_STRING([--enable-ia2],
+ [Enable the Windows IAccessibility2. Disables Java Accessibility Bridge.]),
+,)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -11567,6 +11572,21 @@ fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
dnl ===================================================================
+dnl Test whether to enable ia2
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable IA2])
+ENABLE_IA2=
+if test "$enable_ia2" = "yes"; then
+ if test "$_os" = "WINNT"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_IA2="TRUE"
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST(ENABLE_IA2)
+
+dnl ===================================================================
dnl Test whether to create MSI with LIMITUI=1 (silent install)
dnl ===================================================================
AC_MSG_CHECKING([whether to create MSI with LIMITUI=1 (silent install)])